PC自作で詰まったところメモ。

初めての自作PCは途中何か所か行き詰まりかけたものの、パーツのマニュアルの用語をググったりエラーメッセージをググったりすることでなんとか動くところまで持っていくことができた。所要時間は組み始めてWindowsのインストールが終わるまで、かれこれ6時間くらい。途中立ち往生した箇所について、備忘録として残しておきたい。

配線がわからん

一番最初に躓いたこれが一番の難関だった。正直もう一度やれと言われたら間違えずに正解を引ける自信がない。
マザーボード、グラフィックボード、ケースと電源をどう繋ぐかだけと言えばだけなのだが。

まず電源に何本もついてくるケーブルのどれを使っていいのかが分からん。8ピンと4+4ピンと6+2ピンってどう違うの?
どれが何だか全く分からんまま、24ピン(マザボ)→8ピン(同CPU用)→6+2ピン(グラボ)と消去法でつないでみたらたまたま上手くいった(のだと思う)。

またそれ以上に、ケースのフロントパネルのコネクタの差し方が分かりにくくて困った。
とにかくマザーボード上の表記がめちゃくちゃ小さくて、ケースに固定した後だと見にくいし挿しにくい。またコネクタの差し込み位置はマザボの取扱説明書を見てかろうじてわかったものの、コネクタ側もソケット側も+と−が分からん。なんなんだよGroundって。日本語でおk。
調べると、コネクタで1ピンずつに分かれているものは+−の記載があり、2ピンのものはプラス側に▲マークがあることが分かった。ソケット側はground表記の方がマイナス。で、プラスとプラス、マイナスとマイナスを接続すればよい。

また、世の中にはQコネクタという接続間違い防止用の便利なコネクタが存在するようだ。メーカーの偉い人に言いたいんだけどこれ標準装備にしたほうがいいと思うんですよ。これがなかったばかりに焼き切られてしまったフロントパネルのLEDがこの地上に一体どれだけあるのか考えてみてくださいよ。ていうか俺のケースのLEDも焼き切れてないよな、よく確認してなかったけどなんだか不安になってきたぞ……?

モニター信号なし

必死こいて配線を終え、パーツをなんとかケースに収めて電源をONするとマザボがピカピカ景気良く光りだしたのでやったぜと思ったのだが、モニターに映るのは「信号がありません」の無情な一文であった。
電源やHDMIのケーブルの接続を確かめ差し替えたりしてみたが直る気配がない。結局詰まっていたのは下記の2点だった。

グラボを挿しているときは、ケーブルはグラボ側の映像端子に繋ぐ

何も考えずにマザーボードの背面パネルに挿していたが、グラボを使っているときはグラボ側の端子に接続しないと映像出力されない。グラボの機能を考えれば分かるだろとか言われそうだが、素人はこういうところで詰まるのである。

メモリはちゃんと奥まで挿す

グラボ側の端子に繋いでも一向に変化がないので、2枚挿しのメモリのうち2枚目を一旦抜いて再度起動してみた。BIOS画面が表示された。ビンゴである。
メモリはラッチが元の位置に戻るまでしっかりと挿し込んだつもりだったが、ラッチの反対側がほんの少しだけ緩かったようだ。外見上ではほとんど判別できなかったので、上手く起動できたように見えても、特に複数枚メモリを挿しているときはすべて認識されているかどうかきちんと確認したほうがよい。

BIOS画面からWindowsインストール画面に進めない

そうこうしてBIOS画面に辿り着いたのだが、OSインストールの画面に進めない。
今回は昔購入したWindow7のプロダクトキーを使って、ネットでDLしたWindows10をインストールしたいと考えていた。
で、MacでここからWindows 10 のディスクイメージ (ISO ファイル) をダウンロードし、USBにコピーしてインストールメディアを作成したのだが、BIOS画面で起動先をUSBに指定して試しても、黒い画面が続いてインストール画面に移行しない。

ここで単にコピーするだけではダメなのでは?と気付き(遅い)、UNetbootinを使って改めてインストールメディアを作成してみる。今度はWindowsのインストール画面が表示されたが、途中で「Windowsが必要なファイルC:\ Sources \ Install.wimを開くことができません」というエラーメッセージが出て止まってしまう。

これはインストールメディアの作成方法が悪いのかなと思い、別のWindows機でインストールメディアを作成し再々挑戦。エラーメッセージが出ずに先に進めた。よっしゃ今度は上手くいくだろう、と思った。

Windowsインストール時に再起動ループしてしまう

ダメであった。
具体的には、言語等を設定し、プロダクトキーを入力し、ファイルのコピー等のあと自動的に再起動するのだが、そこで最初の言語等を設定する画面に戻ってしまう。繰り返してもループするだけである。
この原因も後で考えると単純で、通常このインストール手順では、

  1. インストールメディアで起動
  2. →本体ストレージ(HDDまたはSSD)にWindows関連ファイルをコピー
  3. →再起動
  4. →今度はHDDまたはSSD側で起動

という流れで本体にWindowsを設定していくのだが、BIOS画面で誤ってインストールメディアであるUSBを第一優先起動ディスクに指定してしまっていたので、

  1. インストールメディアで起動
  2. →本体ストレージにWindows関連ファイルをコピー
  3. →再起動
  4. →またインストールメディアで起動
  5. →……(以下ループ)

となっていたのだった。
正しくは、BIOS画面で、①優先起動ディスクを本体ストレージに設定した上で、②インストールメディアのUSBから起動を選択する、である。これでUSBでの設定完了後、再起動時には本体ストレージ側で起動することができる。
こうしてようやくWindowsをインストールすることができた。

なんだかんだ2時間くらいで終わるだろと考えていたのだが全くもって見立てが甘く、ここまで辿り着くころには深夜4時近くなっていた。翌日も平日なのに。
自作PCは平日就寝前に作り始めてはいけない。